My Leadership Snapshot is not loading

Summary

This article explains the cause and solution for when your Leadership Snapshot is not displaying within your browser.

Body

Situation:

When trying to launch the Leadership Snapshot the assessment window in Pinpoint has a spinning circle, does not load, and redirects directly back to the Pinpoint home screen instead of launching the assessment.

 

Cause:

This is due to either an assessment Process error or a the assessment scheduling window being passed.

 

Solution:

  1. Reach out to DDI Support (contact information below) and mention your Leadership Snapshot assessment window spins then redirects you to the Pinpoint home screen
  2. We will verify the error and reset your Leadership Snapshot assessment process
  3. We will verify that you are now able to successfully able to access your Leadership Snapshot assessment process.

Details

Details

Article ID: 20156
Created
Wed 8/20/25 9:55 AM
Modified
Wed 3/25/26 2:07 PM