Situation
I completed my Emotional Intelligence Questionnaire and have not receive my results email
Cause:
This is likely due to the email from noreply@ddisurveys.com with your results being held up in your organization's IT Department's email filtering service and/or SPAM folder
Solution:
- Check with your organization's IT Department to see if the results email from noreply@ddisurveys.com was caught in any pre-Inbox email filters and/or your SPAM/Junk folders
- Reach out to DDI Support below with your name, email address, and date you completed the survey so we can forward you the results email
- Take the survey again with a personal (non-organization) email address