What should I do if I encounter a "We're Having Trouble Loading This Page. Please Try Again Later" message?

Tags error browser

 

 

Issue:

Receive the following error message: "We're Having Trouble Loading This Page. Please Try Again Later"

 

Cause:

This is caused by either a change in internet connection (VPN, WiFi, Ethernet, etc.) or a cookies and cache issue with your browser 

 

Solution:

  1. If you are in the middle of an assessment, please call DDI Support using the contact information below
  2. If you are not in the middle of an assessment, please proceed below:
    1. Clear your browser's cookies and cache for "All-time" or use another browser/incognito browser
    2. Log back into Pinpoint using your login URL provided to you